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  SuperMix Preface

Preface
SuperMix combines the functionality of four mixed-effects 
programs, MIXREG, MIXOR, MIXNO, and MIXPREG, into 
a single application to provide estimates for mixed-effects 
regression models. These models can be used for the analysis of 
unbalanced longitudinal data, where each individual may be 
measured at a different number of occasions, even at different 
timepoints. They can also be used for clustered data, where the 
mixed-effects model does not assume that each observation is 
independent, but does assume that data within clusters are 
dependent to some degree.

SuperMix uses a maximum marginal likelihood solution, based 
on a Fisher-scoring algorithm for continuous, ordinal, and 
nominal data; and a Newton-Raphson iterative solution for 
count data.

SuperMix also features data management capabilities and, in the 
PRO version, graphical output.

How to use this manual
(body text)

Exploring the SuperMix work area
(body text)
SuperMix   iii
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Getting Started

System requirements
To run SuperMix you must have certain hardware and software 
installed on your computer. The minimum requirements are:
◗ Windows 95, 98, Me, NT 4.0(SP4), 2000, or XP.
◗ 30 Mb of available hard disk space.
◗ VGA 256-color display or better.
◗ A CD-ROM drive.
◗ A Windows compatible printer to print results. SuperMix 

supports both color and monochrome printers.

Installation
SuperMix is installed on your computer using the program 
SETUP.EXE. If you are installing a software upgrade, it is 
important that you install SuperMix in the same directory as your 
original installation. In most cases, this is probably the SuperMix 
directory in C:\Program Files. However, if you had chosen to 
install your previous version of SuperMix elsewhere, make note 
of its location on your hard drive before you begin installing the 
new version.

The installation program will attempt to find a previously 
installed version of SuperMix, but if it is unsuccessful you must 
specify the location of your existing copy. It is not necessary to 
remove the previous version of SuperMix; the installation 
program will automatically replace the required files without 
altering any of your data.

Windows NT, 2000, and XP users

The SuperMix installation program must work with system files 
that are only accessible to users with administrator rights. If your 
account does not have administrator access rights, you will be 
warned of this and the installation program will not proceed. To 
iv    SuperMix



Getting Started
gain administrator rights, you can either log on to the 
Administrator account (if you have the password) or ask for 
assistance from your computer support technician.

To install SuperMix:

1. Close all currently running Windows applications.
2. If the installation process does not begin automatically, 

locate and run SETUP.EXE from the root directory of 
your computer's CD drive.

3. Follow the prompts.

Quick tour
(body text)
SuperMix   v
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 I - SuperMix Primer

Linear mixed-effects modeling: an applied intro-
duction

Introduction
◗ History of mixed-effects modeling
◗ Different names used to describe mixed-effects models
◗ Review of standard ordinary least squares (OLS).
◗ Interpretation of  intercept and slope parameters.
◗ Graphical display of regression lines for different groups

Sample survey methods
◗ Clustered data
◗ Longitudinal data
◗ Consequence of violating independence assumptions in 

OLS regression models

Mixed-effects modeling
◗ What is a multilevel analysis
◗ Why do a multilevel analysis
◗ The goals of mixed-effects modeling

◗ Estimation of correct standard errors
◗ Parsimony in number of parameters to be estimated 
SuperMix   11



I -  SuperMix Primer
A random-effects model for clustered data
◗ The within-clusters model
◗ The between-clusters model
◗ Distributional assumptions
◗ Interpretation of model parameters
◗ The intra-class correlation coefficient
◗ Illustrative example

◗ Background and description of data
◗ Graphical display and interpretation of  regression lines
◗ Discussion of results

Mixed-effects modeling of longitudinal data
◗ Advantages of mixed-effects models over repeated meas-

ures MANOVA
◗ Random-effects growth modeling
◗ Unconditional growth models

◗ Fixed and random effects
◗ Linear and nonlinear trajectories

◗ Conditional growth models
◗ A single predictor of growth
◗ Two or more predictors of growth

◗ Conditional growth models with time-varying covariates
◗ Illustrative example

◗ Background and description of data
◗ Graphical display of growth trajectories
◗ Discussion and interpretation of results

Special topics
◗ Group- and grand-mean centering

◗ When to use centering
◗ Interpretation of model parameters
12    SuperMix



Mixed-effects modeling for categorical outcome 
◗ Empirical Bayes estimates of regression coefficients
◗ What is an empirical Bayes estimate
◗ Empirical Bayes estimates of subject trends
◗ Confidence intervals
◗ Illustrative example

◗ Standard errors and fit statistics
◗ Handling of missing data and case weights
◗ Extensions to 3-level models

Mixed-effects modeling for categorical outcome 
variables: an applied introduction

Introduction
◗ Types of categorical variables considered
◗ Dichotomous outcomes: logistic regression
◗ Ordinal outcomes: proportional odds and partial odds 

models
◗ Nominal outcomes: nominal logistic regression

Definition and use of link functions
◗ Logit link function
◗ Cumulative logit link function
◗ Probit link function
◗ Complementary log-log link function

Basic models
◗ Random intercept logistic model
◗ Random intercept and trend model
◗ Mixed-effects representation of basic models
SuperMix   13



I -  SuperMix Primer
Basic concepts
◗ Meaning and interpretation of observed and fitted propor-

tions
◗ Meaning and interpretation of observed and fitted odds
◗ Meaning and interpretation of observed and fitted log odds
◗ Meaning and interpretation of observed and fitted logits
◗ Model fit of observed marginal proportions

Illustrative example: Dichotomous logistic regression
◗ Background and description of data
◗ Graphical displays
◗ Discussion and interpretation of results

Illustrative example: Nominal logistic regression
◗ Background and description of data
◗ Graphical displays
◗ Discussion and interpretation of results

Illustrative example: Partial odds model for an ordinal outcome 
variable

◗ Background and description of data
◗ Graphical displays
◗ Discussion and interpretation of results
14    SuperMix



 II - SuperMix Program

Working with SuperMix
Steps needed to get underway:

1. Import data.

2. Set the model definitions correctly.

3. Run the analysis.

SuperMix models
Dependent variable form:
◗ Continuous
◗ Ordered
◗ Nominal
◗ Count

Continuous
MIXREG is a program which provides estimates for a mixed-
effects regression model (MRM) including autocorrelated errors. 
This model can be used for the analysis of unbalanced 
longitudinal data, where each individual may be measured at a 
different number of occasions, even at different timepoints. 
Autocorrelated errors of a general form or following an AR(1), 
MA(1), or ARMA(1) are allowable.

This model can also be used for the analysis of clustered data, 
where the mixed-effects model does not assume that each 

Continuous data
Data that is ordered with a 
constant scale, with or 
without a natural zero.
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observation is independent, but does assume that data within 
clusters are dependent to some degree. The degree of this 
dependency is estimated along with estimates of the usual model 
parameters, thus adjusting these effects for the dependency 
resulting from the clustering of the data.

This model uses a maximum marginal likelihood estimation, 
utilizing both the EM algorithm and a Fisher-scoring solution. 
For the scoring solution, the covariance matrix of the random 
effects is expressed in its Gaussian decomposition, and the 
diagonal matrix reparameterized using the exponential 
transformation. Estimation of the individual random effects is 
accomplished using an empirical Bayes approach.

Ordered
MIXOR is a program that provides estimates for mixed-effects 
ordinal (and binary) regression models.  This model can be used 
for the analysis of clustered or longitudinal (i.e., 2-level) outcome 
data.  Several response functions are available: 
◗ probit
◗ logistic
◗ log-log
◗ complementary log-log

For clustered data, the mixed-effects model does not assume 
that each observation is independent, but does assume that data 
within clusters are dependent to some degree.  The degree of this 
dependency is estimated along with estimates of the usual model  
parameters, thus adjusting these effects for the dependency 
resulting from the clustering of the data.  Similarly, for 
longitudinal data, the mixed-effects approach can allow for 
individual-varying intercepts and slopes across time, and can 
estimate the degree to which these time-related terms vary.  
Model covariates can be either time-varying or time-invariant.

Ordinal data
Data that follows some order 
or continuum, but whose 
values are generally 
arbitrary. Ex. degree of 
toxicity on a scale of 1 to 5.
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SuperMix models
MIXOR uses a maximum marginal likelihood solution, 
specifically implementing a Fisher-scoring algorithm; as a result, 
standard errors are provided for all model terms.  Numerical 
integration is used to integrate over the distribution of random 
effects.  At present, two possibilities are possible for the 
random-effects distribution, namely normal distribution and 
uniform distribution.

For models with one random effect specified or scalar random 
effect multiplication, the program produces empirical Bayes 
estimates of the random effects for each level-2 unit.  These can 
be found in the file MIXOR.RES after running the program.  The 
information in MIXOR.RES is, in order:
◗ level-2 ID
◗ number of level-1 observations
◗ empirical Bayes estimate (the mean of the posterior distri-

bution)
◗ precision associated with the empirical Bayes estimate (the 

standard deviation of the posterior distribution)

Also, for all analyses, two additional files are produced upon 
program completion. MIXOR.EST which contains all parameter 
estimates, and MIXOR.VAR which contains the asymptotic 
variance-covariance matrix of the parameter estimates.

For basic MIXOR usage, as described in the manual published 
in Computer Methods and Programs in Biomedicine (1996), vol 
49:157-176, the user only needs to select options on the first four 
index cards, Configuration, Variables, Starting Values, and 
Missing Values. Simply leave the Advanced index card with its 
default values.

Several new features have been implemented on the Advanced 
index card:
◗ Estimation of partial-proportional odds models
◗ Allowing for right-censoring of the ordinal outcome
User’s Guide   17
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◗ Allowing for different types of random-effect variance 
structure

◗ Allowing the random-effect variance structure to vary by 
level-2 or level-1 covariates.  

Nominal
MIXNO provides maximum marginal likelihood estimates for 
mixed-effects nominal logistic regression analysis. These models 
can be used for the analysis of correlated nominal response data, 
for example, data arising from a clustered design. For clustered 
data, the mixed-effects model assumes the data within clusters 
are dependent.  The degree of dependency is jointly estimated 
with the usual model parameters, thus adjusting for dependence 
resulting from clustering of the data. MIXNO uses marginal 
maximum likelihood estimation, utilizing a Fischer-scoring 
solution. For the scoring solution, the Cholesky factor of the 
random-effects variance-covariance matrix is estimated, along 
with the effects of the model covariates.

Count
MIXPREG provides maximum marginal likelihood estimates 
for mixed-effects Poisson regression analysis.  These models can 
be used for the analysis of correlated count data, for example, 
data arising from a clustered design. The degree of dependency 
is jointly estimated with the usual model parameters, thus 
adjusting for dependence resulting from clustering of the data.  
A Newton-Raphson iterative solution is used in the marginal 
maximum likelihood estimations. Specifically, the Cholesky 
factor of the random-effects variance-covariance matrix is 
estimated, along with the effects of the model covariates.

Defining a model
Model setups are defined using the following tabs:
◗ Configuration

Nominal data
Unordered categorical data. 
Ex. Brand A and Brand B.

Count data
Data that describes 
independent occurrences. 
Eg: number of hospitalization 
instances.
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◗ Variables
◗ Starting Values
◗ Missing Values
◗ Advanced

The SuperMix graphical interface
Before you can run an analysis, you must supply a data source 
for the model. SuperMix allows you to perform analyses from 
data residing in a spreadsheet. When setting up a new 
spreadsheet, you may either enter your data directly, or import 
an existing data file.

Creating SuperMix spreadsheets
SuperMix performs its analyses on data contained in a 
spreadsheet. When setting up a new spreadsheet, you may either 
enter your data directly, or import an existing data file.

To create a new SuperMix spreadsheet:

1. Select File > New. A blank sheet will appear.
2. Copy and paste or type your data into the sheet.

To open a SuperMix spreadsheet:

1. Select File > Open.
2. Locate the file in the directory structure. If necessary 

change the selection in the 'Files of Type' drop menu.
3. Click on Open.

Importing data files
You may import Excel spreadsheets or other data files for use in 
SuperMix. SuperMix will accept fixed-column and delimited file 
formats.
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To import an Excel file: 

1. Select File > Import Data File.
2. Locate the file in the directory structure. 
3. Click on Open.
4. In the next window, select the worksheet name you wish to 

import. SuperMix can import single worksheets only.
5. Click on OK.

OR
Click on Cancel if you wish to stop the import.

To import a data file: 

1. Select File > Import Data File.
2. Select 'All files' in the 'Files of Type' drop menu. Locate the 

file in the directory structure. 
3. Click on Open.
4. In the next window, choose the correct data format: Fixed 

Column or Delimited.
5. If you have selected Delimited, choose the appropriate 

delimiter from the drop down menu.
6. Click on OK.

OR
Click on Cancel if you wish to stop the import.

If you are unsure whether your data file is Fixed Column or 
Delimited, open it in a text editor such as Notepad. Notice how 
the data appears-is it in obvious columns or in a big mass? Data 
that is not in obvious columns must be delimited. Note the 
character separating each record-this is the Delimiter.

Fixed column data
Data in which each column 
has a certain width.
Delimited data
Data whose values are 
separated by tabs, spaces, 
commas, or other characters.

Tip
You may resize the 
spreadsheet by clicking and 
dragging the edges or 
corners. Or, click in the upper 
righthand corner to maximize 
the window.
20    SuperMix



Editing spreadsheets
Saving SuperMix spreadsheets

To save a new SuperMix spreadsheet:

1. In an open spreadsheet, choose File > Save As.
2. In the Save As window, select the folder where you wish to 

save the spreadsheet.
3. In the File Name box, enter a name for the spreadsheet. 

Ensure that 'Save as type: Spread Sheets (.SS3)' is selected 
underneath.

4. Click on Save.

To save an existing SuperMix spreadsheet:

With an open spreadsheet, choose File > Save.

To close a spreadsheet:

Choose File > Close. SuperMix will remain open.

To close all open files and exit SuperMix:

Choose File > Exit.

If you have not saved your open file(s), SuperMix will ask 
whether you wish to save your changes before exiting. 

Editing spreadsheets

Editing cells and cell contents

To edit cell contents:

1. Double-click the cell that contains the data you want to 
edit.

2. Make any changes to the cell contents.
3. To keep your changes, press ENTER. To cancel your 

changes, press ESC.

If you choose File > Save 
with an newly-created 
spreadsheet open, SuperMix 
will ask you to name the 
spreadsheet before saving.
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OR

1. Click on the cell that contains the data you want to edit.
2. Enter the changes in the text box above the spreadsheet.

To delete the contents of a cell:

When deleting a cell's contents, you may choose to delete the 
data in the cell, the formula applied to the cell, or both.
1. Select the cell.
2. Choose Edit > Clear OR right-click and choose Clear.
3. Choose Clear Cell to delete data and formulas.

OR Clear Data to delete the value in the cell while leaving 
the formula intact.
OR Clear Formula to delete the formula for that cell.

Inserting and deleting cells

To delete a cell:

1. Select the cell or range of cells.
2. Choose Edit > Delete Cell (shift up or left).
3. Choose Shift Up or Shift Left. 

Shift Up causes all cells below the deleted cell(s) to shift 
upwards to fill the space. Shift Left causes all cells to the 
right of the deleted cell(s) to shift to the left to fill the 
space.

To insert a cell:

1. Select a cell or range of cells. Select the same number of 
cells as you wish to insert.

2. Choose Edit > Insert Cell (shift down or right).
3. Choose Shift Down or Shift Right.

Shift Down causes all cells below the inserted cell(s) to shift 
downwards to accommodate the new cell(s). Shift Right 

Tip
You may use the DELETE 
key to delete the contents of 
a cell. Select the cell(s) and 
press DELETE.
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causes all cells to the right of the inserted cell(s) to shift to 
the right to accommodate the new cell(s).

To move the contents of a cell to another cell:

When moving a cell's contents to another cell, you may choose 
to move only the value displayed in the cell, or the value and the 
formula that generated it (if you are using formulas).

To move the value only:

1. Select the cell.
2. Choose Edit > Cut

OR right-click and choose Cut
OR type Ctrl + X.

3. Click on the target cell and choose Edit > Paste (value only)
OR right-click and choose Paste (value only)
OR type Ctrl + V.

To move the value and formula of a cell:

1. Select the cell.
2. Choose Edit > Cut

OR right-click and choose Cut
OR type Ctrl + X.

3. Click on the target cell and choose Edit > Paste (with for-
mula)
OR right-click and choose Paste (with formula)
OR type SHIFT + Ctrl + V.

Note that the content in the original cell will not be removed 
until you paste it elsewhere.

Controlling the number of decimal places shown
SuperMix controls the number of decimal places displayed in the 
data. You may set this number with Edit > Set Decimal Place. 
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You may have more than one decimal place setting in a single 
spreadsheet.

To change the number of decimal places shown:

1. Select the cell or group of cells.
2. Choose Edit > Set Decimal Place

OR
Right-click and choose Set Decimal Place.

3. Enter the number of places you would like. The default 
value for this setting is 2.

Please note:

◗ If data is entered with more decimal places than specified 
for that cell, the number will be truncated. If the number of 
decimal places is later increased, then zeros will be 
appended to the values.

◗ Once a number is entered, its precision will be maintained 
even if the number of decimal places is later reduced.

◗ Setting more decimal places than the data has will result in 
trailing zeros.

Editing column headers

To edit a column header:

1. Select the column whose heading you wish to change.
2. Choose Edit > Change Header.
3. Enter the text you wish to use for the header.
4. Click on OK.
OR

1. Right-click in the column header.
2. Choose Change Header from the popup menu.
3. Enter the text you wish to use for the header.
4. Click on OK.
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Editing spreadsheets
 Adjusting the size of columns and rows

To adjust column width:

1. Select the entire column by clicking in the column header.
2. Place the cursor at the header column edge. The cursor will 

change to a horizontal arrow with two vertical bars.
3. Drag the column edge to the desired width.

To adjust row height:

1. Select the entire row by clicking on the row number at the 
left.

2. Place the cursor on the bottom edge of the row. The cursor 
will change to a vertical arrow with two horizontal bars.

3. Drag the row edge to the desired height.

Inserting and deleting columns and rows

To insert a column:

1. Select a column.
2. Choose Edit > Insert Column. A blank column will be 

inserted to the left of your selected column.

To delete a column:

1. Select the column or range of columns.
2. Choose Edit > Delete Column. Columns to the right of the 

deleted column(s) will be shifted to the left.

To insert a row:

1. Select a row.
2. Choose Edit > Insert Row. A blank row will be inserted 

above your selected row.

Tip
To adjust the width of several 
columns at once, select 
multiple columns and drag 
the right edge of the rightmost 
column.

Tip
To adjust the height of several 
rows at once, select multiple 
rows and drag the lower edge 
of the bottom row.
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To delete a row:

1. Select the row or range of rows.
2. Choose Edit > Delete Row. Rows below the deleted row(s) 

will be shifted up.

Using formulas
A formula is an equation that performs operations on 
spreadsheet data. SuperMix allows the use of formulas provided 
they are in the right format.

Formulas can be made up of numerous functions and operators, 
as well as literal numbers and/or cell references.

Example: NEG(SUM(E4:E10)*(B1+36))

SuperMix formula operators and functions

The following operators may be used in formulas:
◗ + (addition)
◗ - (subtraction)
◗ ^ (exponentiation)
◗ * (multiplication)
◗ / (division)
◗ : (creates a range)
◗ # (wild card)
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The following functions may be used in formulas. 

Function Definition

ABS(value) Absolute value

ADD(value1, value2) Addition

AVERAGE(value1, 
value2…)

Average

CEILING(value1, value2) Ceiling

COMBIN(value1, value2) Combination

EVEN(value) Even

EXP(value) Exponent base e

FLOOR(value1, value2) Floor

IF(value1, value2, value3) Comparison

INT(value) Integer

INVERSE(value) Inverse of the specified value

LN(value) Natural log

LOG(value1, value2) Logarithm

LOG10(value) Base 10 logarithm

MAX(value1, value2) Maximum value

MEDIAN(value1, value2…) Median

MIN(value1, value2…) Minimum value

MODE(value1, value2…) Mode

NEG(value) Negative value
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About cell references

Relative references When you create a formula, references to cells or ranges are 
usually based on their position relative to the cell that contains 
the formula. This is known as a relative reference. When you 
copy a formula that uses relative references, SuperMix 
automatically adjusts the references in the pasted formula to 
refer to different cells relative to the position of the formula.

ODD(value) Odd integer

POWER(value1, value2) Raises number to a power

PRODUCT(value1, 
value2…)

Product

RAND () Random number

RANK(Number, Ref, Order) Ranks values

ROUND(value1, value2) Round

ROUNDUP(value1, value2) Round up

SIGN(value) Sign of a number

SQRT(value) Square root

SQUARE(value) Square

STDEV(value1, value2…) Standard deviation

STDEVP(value1, value2…) Standard deviation for population

SUM(value1, value2…) Summation

SUMSQ(value1, value2…) Sum of the squares

VAR(value1, value2…) Variance

VARP(value1, value2…) Variance of population

XROOT(value1, value2…) Root Y of value X
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If you move or copy a formula, and the cells relative to the 
position of the formula are empty in the new location, the cell 
containing the formula will be empty as well.

Absolute references If you don't want SuperMix to adjust references when you copy 
a formula to a different cell, use an absolute reference. For 
example, if your formula multiplies cell A5 with cell C1 
(=A5*C1) and you copy the formula to another cell, SuperMix 
will adjust both references. You can create an absolute reference 
to cell C1 by placing a dollar sign ($) before the parts of the 
reference that do not change. To create an absolute reference to 
cell C1, for example, add dollar signs to the formula as follows:

=A5*$C$1
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 III - SuperMix Examples

Practical applications and level-2 models with con-
tinuous outcome variables

Example 1: Description

Example 2: Description

Practical applications: level-2 models with categor-
ical outcome variables

Example 1: Description

Example 2: Description
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III -  SuperMix Examples
Practical applications and level-3 models with con-
tinuous outcome variables

Example 1: Description

Example 2: Description

Practical applications: level-3 models with categor-
ical outcome variables

Example 1: Description

Example 2: Description
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 IV - SuperMix Syntax

Summary of Syntax

References
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7383 North Lincoln Avenue, Suite 100

Lincolnwood, IL  60712-1704

Phone: +1.847.675.0720
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http://www.ssicentral.com

© 2003 Scientific Software International, Inc. All rights reserved.

This manual describes the programs for mixed-effects models, (also called 

multilevel, hierarchical, and random-effects models) developed by Don Hedeker 

and Robert Gibbons. These programs have been updated and merged into a single 

program.

� Easy to use graphical user interface: import data into the SuperMix spreadsheet, 

then build new models using menus and dialog boxes.  

� Mixed-effects models for continuous outcome variables with auto-correlated 

residuals.

� Mixed-effects models for ordinal regression analysis, including non-proportional 

odds models and scaling effects.

� Mixed-effects models for Poisson regression analysis.

� Mixed-effects models for nominal logistic regression analysis.

� Mixed-effects models for grouped-time survival analysis.

� Accepts old definition files created by MIXREG, MIXOR, MIXNO, and MIXPREG.

� Two- and three-level models allowing for nested designs.   

� Presentation quality graphics.

SuperMix
Robert D. GibbonsDonald Hedeker
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