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THE DIAGNOSIS AND TREATMENT OF NON-NORMALITY 
 
 
 

 
1. Introduction 
Several statistical methods for structural equation modeling such as the Maximum 
Likelihood (ML), Generalized Least Squares (GLS) and Full Information Maximum 
Likelihood (FIML) methods for standard and multilevel structural equation modeling assume 
that the data follow a multivariate Normal distribution.  In practice, however, the assumption 
of a multivariate Normal data distribution often does not hold.  Consequently, alternative 
methods such as Weighted Least Squares (WLS), Diagonally Weighted Least Squares 
(DWLS) and Robust Maximum Likelihood (RML) are recommended to fit structural equation 
models to these data sets.  Another option would be to fit the structural equation models to 
the Normal Scores rather than to the original data. 
 
Mardia (1970, 1974, 1985) and Mardia & Foster (1983) proposed numerous methods to 
assess the normality of the data to be analyzed.  More specifically, these methods are 
statistical tests for marginal skewness and kurtosis as well as multivariate skewness and 
kurtosis.  These tests as well as the Weighted Least Squares (WLS), Diagonally Weighted 
Least Squares (DWLS) and Robust Maximum Likelihood (RML) methods for structural 
equation modeling are available in LISREL 8.7 for Windows (Jöreskog & Sörbom 2004).  In 
addition, LISREL 8.7 for Windows also includes Normal Scores.  The methods of Normal 
Scores, WLS, DWLS and RML are described in Jöreskog et al (2001) while the normality 
tests are outlined in Jöreskog & Sörbom (1999). 
 
In this note, the normality tests and the Normal Scores, WLS, and RML methods of LISREL 
8.7 for Windows are illustrated by using a multivariate data set consisting of the scores of a 
sample of school children on nine psychological tests and a measurement model.  This 
data set is described in the next section.  The measurement model is described in section 
3.  Section 4 illustrates the normality tests.  Thereafter, the method of Normal Scores is 
used to fit the measurement model to the data set.  In section 6, the measurement model is 
fitted to the data by means of the WLS and RML methods. 
 
 
 
2. The Data 
The data are the scores on nine psychological tests of 145 seventh- and eighth-grade 
students at the Grant-White school in Chicago.  The raw data are listed in the PRELIS 
System File (PSF) NPV.PSF in the WORKSHOP subfolder of the LISREL 8.7 for Windows 
installation folder.  The first couple of lines of this file are shown in the following PSF 
window. 
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3. The Measurement Model 
We consider nine psychological tests that were administered to 145 seventh- and eighth-
grade students.  These nine psychological tests are theoretically constructed to measure 
the visual perception, verbal ability and numerical speed of seventh- and eighth-grade 
children.  A path diagram for the corresponding measurement model for visual perception, 
verbal ability and numerical speed is shown in Figure 1. 
 
Figure 1: A path diagram for a measurement model of Visual Perception,  
                Verbal Ability and Numerical Speed 

 
4. Normality Tests 
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 Use the Open option on the File menu to load the Open dialog box. 
 Browse for the WORKSHOP folder of the LISREL 8.7 for Windows installation folder. 
 Select the PRELIS Data (*.psf) option from the Files of type dropdown list box. 
 Select the file NPV.PSF. 
 Click on the Open push button to open the PSF window for NPV.PSF. 
 Select the Output Options option on the Statistics menu of the PSF window to load 

the Output dialog box. 
 Check the Perform tests of multivariate normality checkbox. 
 Click on the OK push button of the Output dialog box to run PRELIS27.EXE to produce 

the text editor window for NPV.OUT. 
 
The results for the univariate and multivariate tests of normality are shown in the following 
two text editor windows respectively. 
 

 
 
 

 
 
 
From the results above, it seems that there is sufficient evidence that the assumption of a 
multivariate Normal data distribution may be violated. 
 
5. Using Normal Scores 
Normal Scores 
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 Select the Close all option on the Windows menu to close all open windows. 
 Use the Open option on the File menu to load the Open dialog box. 
 Browse for the WORKSHOP folder of the LISREL 8.7 for Windows installation folder. 
 Select the PRELIS Data (*.psf) option from the Files of type dropdown list box. 
 Select the file NPV.PSF. 
 Click on the Open push button to open the PSF window for NPV.PSF. 
 Select the Normal Scores option on the Statistics menu of the PSF window to load the 

Normal Scores dialog box. 
 Select all the labels in the Variable List box. 
 Click on the Add push button to produce the following Normal Scores dialog box. 

 
 

 Click on the Output Options push button to load the Output dialog box. 
 Check the Save the transformed data to file checkbox in the Data section. 
 Enter the name NPV_NS.PSF in the string field. 
 Click on the OK push button of the Output dialog box to return to the Normal Scores 

dialog box. 
 Click on the Run push button of the Normal Scores dialog box to run PRELIS27.EXE 

to produce the text editor window for NPV.OUT. 
 

 Select the Close all option on the Windows menu to close all open windows. 
 Use the Open option on the File menu to load the Open dialog box. 
 Browse for the WORKSHOP folder of the LISREL 8.7 for Windows installation folder. 
 Select the PRELIS Data (*.psf) option from the Files of type dropdown list box. 
 Select the file NPV_NS.PSF. 
 Click on the Open push button to open the PSF window for NPV_NS.PSF. 
 Select the Define Variables option on the Data menu to load the Define Variables 

dialog box. 
 Select all the labels in the list box. 
 Click on the Missing Values push button to load the Missing Values for … dialog box. 
 Activate the Listwise Deletion radio button. 
 Select the Output Options option on the Statistics menu of the PSF window to load 

the Output dialog box. 
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 Check the Perform test of multivariate normality checkbox. 
 Click on the OK push button of the Output dialog box to run PRELIS27.EXE to produce 

the text editor window for NPV_NS.OUT. 
 
The results for the univariate and multivariate tests of normality are shown in the following 
two text editor windows respectively. 

 

 
 
 

 
 
From the results above, it seems that there is insufficient evidence that the assumption of a 
multivariate Normal data distribution may be violated. 
 
 
 
 
 
 
 
 
 
Fitting the Measurement Model to the Normal Scores 

 Select the Close all option on the Windows menu to close all open windows. 
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 Use the New option on the File menu of the root window to load the New dialog box. 
 Select the Path Diagram option from the list box on the New dialog box to load the 

Save As dialog box. 
 Enter NPV.PTH in the File name string field. 
 Click on the Save push button to open an empty path diagram window. 
 Select the Title and Comments option on the Setup menu to load the Title and 

Comments dialog box. 
 Enter A measurement model for nine psychological tests in the Title string field. 
 Click on the Next push button to load the Group Names dialog box. 
 Click on the Next push button to load the Labels dialog box. 
 Click on the Add/Read Variables push button to load the Add/Read Variables dialog 

box. 
 Select the PRELIS System File option in the Read from file: dropdown list box. 
 Click on the Browse push button to load the Browse dialog box. 
 Select the file NPV_NS.PSF. 
 Click on the Open push button to return to the Add/Read Variables dialog box. 
 Click on the OK push button to return to the Labels dialog box. 
 Click on the Add Latent Variables push button to load the Add Variables dialog box. 
 Enter the label Visual for visual perception in the string field. 
 Click on the OK push button to return to the Labels dialog box. 
 Click on the Add Latent Variables push button to load the Add Variables dialog box. 
 Enter the label Verbal for verbal ability in the string field. 
 Click on the Add Latent Variables push button to load the Add Variables dialog box. 
 Enter the label Numerical for numerical speed in the string field. 
 Click on the OK push button to produce the following Labels dialog box. 

 

 
 

 Click on the OK push button to return to the PTH window for NPV.PTH. 
 Click, drag and drop the labels of the observed variables one at a time into the PTH 

window. 
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 Click, drag and drop the labels of the latent variables one at a time into the PTH window 
to produce the following PTH window. 

 
 
 

 Select the arrow icon on the drawing toolbar. 
 Click and drag paths from Visual to VISPERC, CUBES, LOZENGES and SCCAPS 

respectively. 
 Click and drag paths from Verbal to PARCOMP, SENCOMP and WORDMEAN 

respectively. 
 Click and drag paths from Numerical to ADDITION, COUNTDOT and SCCAPS 

respectively to produce the following PTH window. 
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 Select the Build SIMPLIS Syntax option on the Setup menu to open the following 
SIMPLIS project window. 

 
 

 
 
 

 Click on the Run LISREL icon on the main toolbar to produce the following PTH 
window. 

 
 

 
 
 
 
6. The RML and WLS Methods 
Generating the Data System File (DSF) 
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 Select the Close all option on the Windows menu to close all open windows. 
 Use the Open option on the File menu to load the Open dialog box. 
 Browse for the WORKSHOP folder of the LISREL 8.7 for Windows installation folder. 
 Select the PRELIS Data (*.psf) option from the Files of type dropdown list box. 
 Select the file NPV.PSF. 
 Click on the Open push button to open the PSF window for NPV.PSF. 
 Select the Output Options option on the Statistics menu to load the Output dialog 

box. 
 Check the Save to File checkbox in the Asymptotic Covariance Matrix section. 
 Enter the name NPV.ACM in the string field in the Asymptotic Covariance Matrix 

section. 
 Click on the OK push button to run PRELIS27.EXE to generate the text editor window 

containing the output file NPV.OUT. 
 
The RML Method 

 Select the Close all option on the Windows menu to close all open windows. 
 Use the Open option on the File menu to load the Open dialog box. 
 Browse for the WORKSHOP folder of the LISREL 8.7 for Windows installation folder. 
 Select the SIMPLIS Project (*.spj) option from the Files of type dropdown list box. 
 Select the file NPV.SPJ. 
 Click on the Open push button to open the SPJ window for NPV.SPJ. 
 Use the Save As option on the File menu of the root window to load the Save As dialog 

box. 
 Enter the name NPV_RML.SPJ in the File name string field. 
 Click on the Save push button to open the SPJ window for NPV_RML.SPJ. 
 Change the second line Raw Data from File NPV_NS.PSF to System File from File 

NPV.DSF to create the following SPJ window. 

 
 
 

 Click on the Run LISREL icon on the main toolbar to produce the following PTH 
window. 
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The WLS Method 
 Select the Close all option on the Windows menu to close all open windows. 
 Use the Open option on the File menu to load the Open dialog box. 
 Browse for the WORKSHOP folder of the LISREL 8.7 for Windows installation folder. 
 Select the SIMPLIS Project (*.spj) option from the Files of type dropdown list box. 
 Select the file NPV_RML.SPJ. 
 Click on the Open push button to open the SPJ window for NPV_RML.SPJ. 
 Use the Save As option on the File menu of the root window to load the Save As dialog 

box. 
 Enter the name NPV_WLS.SPJ in the File name string field. 
 Click on the Save push button to open the SPJ window for NPV_WLS.SPJ. 
 Insert the line Method of Estimation: Weighted Least Squares just before the Path 

Diagram command to create the following SPJ window. 
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 Click on the Run LISREL icon on the main toolbar to produce the following PTH 

window. 
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