Multilevel modeling

1. Introduction

In practice, many multivariate data sets are obtained by using complex sampling designs.
Cluster sampling is a very popular sampling method if the target population has a multilevel
(hierarchical) structure such as educational target populations for which students are
nested within schools that are again nested in education departments. It is a well-known
fact that alternative statistical methods are required to analyze multilevel data sets in an
appropriate fashion (see e.g. Goldstein (1987, 1995)). Statistical software such as MLWin,
SAS PROC MIXED, and HLM are used to fit linear and nonlinear models appropriately to
hierarchical data sets.

The statistical application MULTILEV8 of LISREL 8.80 for Windows (JOoreskog & Sdrbom
2006) may also be used to fit linear and nonlinear models appropriately to hierarchical data
sets. More details on MULTILEV8 are available in Du Toit & Du Toit (2001) while
comprehensive technical details on the corresponding statistical methods are provided in
Joreskog et al (2001).

In this note, MULTILEVS8 is used to analyze air traffic control data and multivariate
education data. The air traffic control data set is described in the next section. Thereafter, a
variance decomposition model and a non-linear model without and with additional variables
are fitted to the air traffic control data. A multivariate educational data set is described in
Section 4. In Section 5, a multivariate multilevel analysis of the educational data is
performed.

2. The air traffic control data

The data used in this example are described in Kanfer & Ackerman (1989). The data
consist of information for 141 U.S. Air Force enlisted personnel. The personnel carried out
a computerized air traffic controller task developed by Kanfer and Ackerman.

The subjects were instructed to accept planes into their hold pattern and land them safely
and efficiently on one of four runways, varying in length and compass directions, according
to rules governing plane movements and landing requirements. For each subject, the
success of a series of between three and six 10-minute trials was recorded. The
measurement employed was the number of correct landings per trial. The Armed Services
Vocational Battery (ASVB) was also administered to each subject. A global measure of
cognitive ability, obtained from the sum of scores on the 10 subscales, is also included in
the data. The raw data are provided in the PRELIS System File (PSF) KANFER.PSF. This
file is located in C:\LISREL 8.8 Student Examples\MLEVELEX. The first potion of this file
is shown in the following PSF window.
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¥ KANFER.PSF O] x|
control time Mmeasure ability constant I timesq I

1 1.000 £4.000 142160 1.000 1.000 -

2 1.000 2.000 27.000 142160 1.000 4000 |
3 1.000 3.000 30.000 142160 1.000 5.000
4 1.000 4.000 3e2.000 142160 1.000 16.000
b 1.000 5.000 36.000 142160 1.000 2b.000
b 1.000 k.000 41.000 142160 1.000 36.000
Fi 2.000 1.000 2.000 -7.630 1.000 1.000
8 2.000 2.000 3.000 -7.630 1.000 4.000
9 2.000 3.000 5.000 -7.630 1.000 5.000
10 2.000 4.000 13.000 -7.630 1.000 16.000
11 2.000 5.000 13.000 -7.630 1.000 £b.000
12 2.000 B.000 14.000 -7.630 1.000 36.000
13 3.000 1.000 12.000 -67.430 1.000 1.000
14 3.000 2.000 18.000 -67.430 1.000 4.000

15 3.000 3.000 24.000 -67.430 1.000 9.0000

e < TN W——r T + e Wmﬂ_l

The variables in the data set above are the identifying number of the air traffic controller
(control), the number of the trial (ranging from 1 to 6) (time), the number of successful
landings for the trial (measure), the cognitive ability score (combined ASVB score)
(ability), the intercept term (constant), with value 1 throughout and the square value of the
number of the trial (timesq).

3. The analysis of the air traffic control data

The variance decomposition model

In the case of the air traffic control data, the variance decomposition model enables us to
investigate the variation in the number of correct trials over subjects and also over the six
measurements for each subject.

Select the Open option on the File menu to load the Open dialog box.

Select the PRELIS data (*.psf) option from the Files of type: dropdown list box.
Browse for the location C:\LISREL 8.8 Student Examples\MLEVELEX.

Select the file KANFER.PSF by clicking on it.

Click on the Open button to open KANFER.PSF in a PSF window.

Select the Title and Options option on the Linear Model pop-up menu of the
Multilevel menu of the PSF window to load the Title and Options dialog box.

Enter A variance decomposition model in the Title string field.

Click on the Next button to load the Identification variables dialog box.

Select the variable control by clicking on it.

Click on the Add button of the Level 2 ID Variable section.

Click on the Next button to load the Select Response and Fixed Variables dialog box.
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» Select the variable measure by clicking on it.

» Click on the Add button of the Response Variables section.

» Click on the Next button to load the Random Variables dialog box.

» Click on the Finish button to open the following text editor window for KANFER.PR2.

| 8 LISREL for Windows - [KANFER.PR2] L OX
|: Fle Edit Options Window Help - 8 x
D/e|es| ] & ||| &k S/A/2

OPTIONS OLS=YES CONVERGE=0.001000 MAXITER=10 OUTPUT=STANDARD ; *
TITLE=A variance decomposition model;

SY="C:\LISREL &.8 Student Examples\MLEVELEX\KANFER PSF';
ID2=control;

RESPONSE=measure;

FIXED=1ntcept ;

RANDOM1=1ntcept;

RANDOMZ2=1ntcept ;

h=n
(£

» Click on the Run PRELIS icon on the main toolbar to produce the following text editor
window for KANFER.OUT.

8 LISREL for Windows - [KANFER.OUT] L OX
[, Fle Edt oOptons Window Help -8 x
D55 m] & [w[@| «[+| s(A]e
P + 3
| RANDOM PART OF MODEL |
oo __ +
LEVEL 2 TAU-HAT STD ERR Z-VALUE PR > |Z]
intcept /intcept 47 22048 7.51714 6.28200  0.00000
LEVEL 1 TAU-HAT STD.ERR Z-VALUE PR = |Z] =
intcept /intcept 92 17651 403041 18.60552  0.00000
W
A s
Ready
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A Non-linear Growth Model

> Select the Close all option on the Window menu to close all open windows.

» Select the Open option on the File menu to load the Open dialog box.

» Browse for the location C:\LISREL 8.8 Student Examples\MLEVELEX.

» Select the file KANFER2.PR2 by clicking on it.

» Click on the Open button to open the following text editor window for KANFER2.PR2.

8 LISREL for Windows - [KANFER2.PR2] =]Ed
|j Fle Edit Options Window Help - 8 x

D/e|es| ] & ||| &k S/A/2

I In the syntax below the variable "constant" was replaced with
I "intcept" (the default in LISREL 2.7). The "intcept" variable
I need not be in the P5F-Tile. No ID1=<varname> is required.

OPTIONS OLS=YES CONVERGE=0.0001 MAXITER=10 OUTPUT=BAYES ;
TITLE=Kanfer and Ackerman data: non-Tlinear model ;
SY=KANFER . PSF;

IDZ2=control ;

RESPONSE=measure;

FIXED=intcept time timesq;

RANDOM1=1intcept ;

RANDOMZ=1intcept time timesq;

£

Line 6 specifies the options for the multilevel modeling method.

Line 7 specifies a title for the analysis.

Line 8 specifies the raw data source.

Lines 9 specifies the identification variable for the second level.

Line 10 specifies the response variable.

Line 11 specifies the fixed variables.

Lines 12 and 13 specify the random variables for the two levels.

» Click on the Run PRELIS icon on the main toolbar to produce the following text editor
window for KANFER2.OUT.
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| & LISREL for Windows - [KANFER2.0UT]
[} Fie Edt Optons Window Help
D[l m| & (w@ || S8 2

intcept 1.67806 0.87343 1.92124 0.05470
time 11.48966 0.50397 22.79847 0.00000
timesqg -16.86770 0.00000

A Non-linear Growth Model with an Additional Variable

Select the Close all option on the Window menu to close all open windows.
Select the Open option on the File menu to load the Open dialog box.
Browse for the location C:\LISREL 8.8 Student Examples\MLEVELEX.
Select the file KANFER3.PR2 by clicking on it.

YVVYYVY

| & LISREL for Windows - [KANFER3.PRZ] L OX
- | B X

[ Fle Edt Optons Window Help
Dlles|m| & |%|@| #i2| S(A[2)

Click on the Open button to open the following text editor window for KANFER3.PR2.

I In the syntax below the variable "constant" was replaced with
I "intcept" (the default in LISREL &.7). The "intcept" variable
! need not be in the PS5F-file. No ID1=<varname= 15 required.

OPTIONS OLS=YES CONVERGE=0.0001000 MAXITER=10 OUTPUT=STANDARD ;
TITLE=Kanfer and Ackerman data: non-1inear model plus ability;
SY=KANFER .PSF;

ID2=control;

RESPONSE=measure;

FIXED=1ntcept time timesqg ability;

RANDOM1=1ntcept ;

RANDOMZ=1ntcept time timesq;

£
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Line 6 specifies the options for the multilevel modeling method.
Line 7 specifies a title for the analysis.

Line 8 specifies the raw data source.

Line 9 specifies the identification variable for the second level.
Line 10 specifies the response variable.

Line 11 specifies the fixed variables.

Lines 12 and 13 specify the random variables for the two levels.

> Click on the Run PRELIS icon on the main toolbar to produce the following text editor
window for KANFER3.OUT.

& LISREL for Windows - [KANFER3.0UT] L OX
|: Fle Edit Options Window Help - 8 x
D[] /8@ «0| a/fe
e + A
| FIXED PART OF MODEL |
oo ____ +
COEFFICIENTS BETA-HAT STD.ERR Z-VALUE PR
intcept 1.67596 078914 2 12380 0.0
time 1140203 050393 2280468 0.0
timesq -1.03639 006140 -16_87926 0.0
ability 003703 000519 7 12991 0.0
o e __ +
| -2 LOG-LIKELIHOOD |
oo ____ +
DEVIANCE= -2*LOG({LIKELIHOOD) = 5052.791958760214 v
<1 >
Ready
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4. The Educational Data

The data set used in this section forms part of the data library of the Multilevel Project at
the University of London and comes from the Junior School Project (Mortimer,et al.,1988).
Mathematics and language tests were administered in three consecutive years to more
than 1000 students from 50 primary schools, which were randomly selected from primary
schools maintained by the Inner London Education Authority. The raw data are provided in
the PRELIS System File (PSF) JSP.PSF. This file is available in C:\LISREL 8.8 Student
Examples\MLEVELEX. The first potion of this file is shown in the following PSF window.

ﬁ ~10) x|
school student gender ravens I math1 I math? I

1 1.000 0.000 23.000 23.000 24000

2 1.000 2.000 1.000 15.000 14.000 11.000 _|
3 1.000 3.000 1.000 22000 36.000 32.000
4 1.000 4.000 1.000 14.000 24.000 ¢h.000
5 1.000 h.000 0.000 19.000 22000 23.000
b 1.000 6.000 0.000 16.000 19.000 23.000
Fi 1.000 7.000 1.000 17.000 22.000 22.000
[i] 1.000 8.000 0.000 21.000 18.000 29.000
q 1.000 9.000 1.000 30.000 30.000 31.000
10 1.000 10.000 0.000 26.000 29.000 29.000
11 1.000 11.000 0.000 32.000 31.000 28.000
12 1.000 12.000 0.000 16.000 18.000 ¢h.000
13 1.000 13.000 0.000 25.000 23.000 -9.000
14 1.000 14.000 0.000 29.000 39.000 35.000

15 1.000 16.000 0.000 34.000 24.000 300000 _

— m—"T Y T Sr-Ys E—T Yy p——yy LIJ

Note that the —9.000 entries represent missing values.

The variables in JSP.PSF are the school code (1 to 50) (school), Student ID (student),
gender (gender), ravens test score in year 1 (ravens), score on mathematics test in year 1
(math1l), score on mathematics test in year 2 (math?2), score on mathematics test in year 3
(math3), score on language test in year 1 (engl), score on language test in year 2 (eng2),
score on language test in year 3 (eng3) and the intercept value (constant).
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5. The Analysis of the Education Data

The Variance Decomposition Model

Select the Close all option on the Window menu to close all open windows.
Select the Open option on the File menu to load the Open dialog box.

Browse for the location C:\LISREL 8.8 Student Examples\MLEVELEX.

Select the file JSP1.PR2 by clicking on it.

Click on the Open button to open the following text editor window for JSP1.PR2.

YVVYVYYVYV

¥ Jsp1.Pr2

I In the syntax below the variable "constant" was replaced with
I "intcept" (the default in LISREL 8.7). The "intcept" variable
| need not be in the PSF-Tile. No ID1=<varname> is required.

OPTIONS Maxiter=30 Conv=0.0001 CovBW=Yes ACM=Yes;
TITLE=Multivariate Analysis of Education Data;
SY=I5P PSEL

ID2=student;

ID3=school ;

RESPONSE=math1 math2 math3 eng1 eng2 eng3;
FIXED=intcept;

MISSING_DEP=-9;

Line 6 specifies the default options for the multilevel modeling method.

Line 7 specifies a title for the analysis.

Line 8 specifies the raw data source.

Lines 9 and 10 specify the identification variables for levels 2 and 3 respectively.
Line 11 specifies the response variables.

Line 12 specifies the fixed variable.

Line 13 specifies the missing value code as —9.0.

» Click on the Run PRELIS icon on the main toolbar to produce the following text editor
window for JSP1.0OUT.
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F¥ uspi.ouT L OX

LEVEL 3 COVARIANCE MATRIX

math1 math2 engz

.31028

.29203

.38877 L ;

.95162 : : 59.32680

-93290 : 1 4249228 93.085985
-16830 : : 45.00410 51.61419

eng3
£ )i

A Model with Explanatory Variables

Select the Close all option on the Window menu to close all open windows.
Select the Open option on the File menu to load the Open dialog box.

Browse for the location C:\LISREL 8.8 Student Examples\MLEVELEX.

Select the file JSP2.PR2 by clicking on it.

Click on the Open button to open the following text editor window for JSP2.PR2

B¥ Jsp2.PR2 EJI@

YVVYVYYVYYV

I In the syntax below the variable "constant" was replaced with
I "intcept" (the default 1n LISREL &.7). The "intcept" variable
I need not be in the PSF-file. No ID1=<varname= 13 required.

OPTIONS Maxiter=30 Conv=0.0001 Summary=None;

TITLE=Multivariate Analysis of Education Data, added fTixed effects;
SY=JSP .PSF;

ID2=student;

ID3=school ;

RESPONSE=math1 mathZ math3 engl eng2 eng3;

FIXED=1ntcept gender ravens;

MISSING_DEP=-9;

i

2]

Line 6 specifies the default options for the multilevel modeling method.

Line 7 specifies a title for the analysis.

Line 8 specifies the raw data source.

Lines 9 and 10 specify the identification variables for levels 2 and 3 respectively.

Line 11 specifies the response variables.

Line 12 specifies the fixed variables.

Line 13 specifies the missing value code as -9.0.

» Click on the Run PRELIS icon on the main toolbar to produce the following text editor
window for JSP2.0OUT.
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B¥ Jsp2.ouT

intcept1
intcept2
intcept3
intcept4
intcept5s
intcept6
gender
genderz
gender3
gender4
genders
gendere
ravens?
ravensz2
ravens3
ravens4
ravenss
ravense

-00000
.00000
.36197
.00000
.34741
.15138
.03139
.18159
-00000
.00000
.00000
.00000
-00000
.00000
.00000
.00000
-00000

OO0 000—_,==000NNMNNODOODO
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