An introduction to LISREL 8.80 for Windows
1. Introduction
LISREL 8.80 for Windows (Jöreskog & Sörbom 2006) is a Windows software product for
structural equation modeling, multilevel structural equation modeling, generalized linear
modeling, multilevel linear modeling, multilevel generalized linear modeling, multilevel
nonlinear modeling, and formal inference-based recursive modeling. This product consists
of a 32-bit Windows Graphical User Interface (GUI) application LISWIN that interfaces with
the 32-bit statistical applications LISREL, PRELIS, MULTILEV, SURVEYGLIM, MAPGLIM,
CATFIRM, and CONFIRM.
PRELIS is a 32-bit application for manipulating data, transforming data, generating data,
computing moment matrices, computing asymptotic covariance matrices, performing
multiple linear, censored, logistic, and probit regression analyses, performing exploratory
factor analyses for continuous and ordinal variables, etc.
The 32-bit application LISREL is intended for standard and multilevel structural equation
modeling. The Full Information Maximum Likelihood (FIML) method for incomplete data is
also available for both standard and multilevel structural equation modeling. In the case of
continuous variables, standard structural equation modeling is also available for complex
survey data.
MULTILEV fits multilevel linear and nonlinear models to raw data. In the case of continuous
response variables, MULTILEV allows for design weights at each level of the hierarchy.
SURVEYGLIM fits generalized linear models to simple random sample and complex survey
data.
MAPGLIM fits generalized linear models to multilevel data.
CATFIRM and CONFIRM implement formal inference-based recursive modeling for raw
categorical and continuous data respectively.
LISREL 8.80 for Windows imports external data in formats such as SPSS, SAS, STATA,
Statistica, Microsoft Excel, SYSTAT, BMDP, etc. as a PRELIS System File (PSF).
This document is intended as a brief overview to familiarize new users of LISREL 8.80 for
Windows with the features of the application. Section 2 describes the various files used and
generated by LISREL 8.80 for Windows. A procedure to import an SPSS data file as a PSF
to be used by LISREL 8.80 for Windows is described in Section 3. Some of the descriptive
graphics of LISREL 8.80 for Windows are illustrated in Section 4. A data screening, a
multiple linear regression analysis, and a logistic regression analysis with LISREL 8.80 for
Windows are illustrated in Sections 5, 6, and 7 respectively. Section 8 demonstrates an

An introduction to LISREL 8.80 for Windows

1

exploratory factor analysis for continuous and ordinal variables with LISREL 8.80 for
Windows. Section 9 illustrates how LISREL 8.80 for Windows can be used to run SIMPLIS
syntax files. Section 10 demonstrates some of the features of the path diagram (PTH)
window of LISREL 8.80 for Windows. The use of LISREL syntax files is illustrated in
Section 11.

2. Files
LISREL 8.80 for Windows uses a PRELIS System File (PSF) to store raw data. The
statistical applications LISREL, PRELIS, MULTILEV, SURVEYGLIM, and MAPGLIM read
the raw data values directly from a PSF.
Whenever PRELIS or LISREL processes a PSF, a Data System File (DSF), which has the
same file name as the PSF, but with a DSF extension, is created. This DSF contains all the
summary data information that LISREL requires to fit standard structural equation models
to complete data.
A structural equation model can be specified by means of a path diagram, a SIMPLIS
project file, a LISREL project file, a SIMPLIS syntax file, or a LISREL syntax file. LISREL
8.80 for Windows uses a graphics file with the default extension PTH to capture a path
diagram. The extensions SPJ and LPJ are used for SIMPLIS and LISREL project files
respectively. SIMPLIS and LISREL syntax files are text files with the default extensions
SPL and LS8 respectively. These five file types access the raw data from the PSF or the
summary data from the DSF. If a user has prepared any of these files, then LISWIN and
LISREL can be used to fit the specified model to the raw data specified in the
corresponding PSF or the summary data in the corresponding DSF.
Path diagram, SIMPLIS project and LISREL project files are described in Du Toit & Du Toit
(2001). SIMPLIS syntax files are described in Jöreskog & Sörbom (1999c) while LISREL
syntax files are outlined in Jöreskog & Sörbom (1999b). All these files are also described in
the online help file, which can be accessed by using the LISREL Help option on the Help
menu of LISREL 8.80 for Windows. In addition, SIMPLIS syntax files are also described in
http://www.ssicentral.com/lisrel/techdocs/SIMPLISSyntax.pdf
while LISREL syntax files are described in
http://www.ssicentral.com/lisrel/techdocs/LISRELSyntax.pdf#pagemode=bookmarks
Whenever PRELIS processes a PSF interactively, a PRELIS syntax file with the same file
name as the PSF is created. A PRELIS syntax file is a text file with default extension PR2.
PRELIS syntax files are described by Jöreskog & Sörbom (1999a) as well as in the online
help file of LISREL 8.80 for Windows and in
http://www.ssicentral.com/lisrel/techdocs/IPUG.pdf
Multilevel modeling, generalized linear modeling, multilevel generalized
and formal inference-based recursive modeling syntax files are also text
extension PR2. Multilevel modeling and generalized linear modeling
described in Du Toit et al. (2005) while formal inference-based recursive
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files are described in Du Toit & Du Toit (2001). These types of syntax files are also
described in the online help file of LISREL 8.80 for Windows. MULTILEV and
SURVEYGLIM syntax files are also described in
http://www.ssicentral.com/lisrel/techdocs/MLUG.pdf
and
http://www.ssicentral.com/lisrel/techdocs/SGUG.pdf#pagemode=bookmarks
respectively.
LISREL 8.80 for Windows starts up by opening a main window with three menus entitled
File, View, and Help. The Open option on the File menu is used to open an existing PSF
or PTH file in a PSF and a PTH window respectively. It can also be used to open existing
LISREL and SIMPLIS project files in LISREL and SIMPLIS project (LPJ and SPJ) windows.
Text editor windows are used to display existing syntax files and output files. PTH, PSF,
LPJ, SPJ and text editor windows have window-specific menus.
The LISREL Help option on the Help menu opens the online help file of LISREL 8.80 for
Windows. The About LISREL option loads the About LISREL dialog box which shows the
product information for LISREL 8.80 for Windows.

3. Importing data as a PRELIS System File (PSF)
The PRELIS System File (PSF) is a binary file that LISREL 8.80 for Windows uses to store,
display and analyze raw data. LISREL 8.80 for Windows opens a PSF in a PSF window
with menus entitled File, Edit, Data, Transformation, Statistics, Graphs, Multilevel,
SurveyGLIM, View, Window, and Help. In this section, we will import an SPSS data file as
a PSF. Then, we demonstrate how to set up the PSF for further processing with LISREL
8.80 for Windows.
The Data
The data set forms part of the data library of the Multilevel Project at the University of
London, and emanates from the Junior School Project (Mortimore et al, 1988).
Mathematics and language tests were administered in three consecutive years to more
than 1000 students from 50 primary schools, which were randomly selected from primary
schools maintained by the Inner London Education Authority. The data are provided in the
location C:\LISREL 8.8 Student Examples\WORKSHOP as the SPSS data file
JSP2.SAV. The first portion of this file is shown in the following SPSS data window.
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Creating the PSF
¾ Use the Import Data option from the File menu of the main window of LISREL 8.80 for
Windows to load the Open dialog box.
¾ Select SPSS for Windows (*.sav) from the Files of type dropdown list box.
¾ Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.
¾ Select the file JSP2.SAV by clicking on it.
¾ Click on the Open button to load the Save As dialog box.
¾ Enter the name JSP2 in the File name string field.
¾ Click on the Save button to open the following PSF window.
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Note that the –9.000 entries refer to missing values.
Prepare the PSF for Data Processing
¾ Select the Define Variables option on the Data menu to load the Define Variables
dialog box.
¾ Select the labels MATH1, MATH2, MATH3, ENG1, ENG2, and ENG3.
¾ Click on the Variable Type button to load the Variable Types for … dialog box.
¾ Activate the Continuous radio button.
¾ Click on the OK button on the Variable Types for … dialog box.
¾ Click on the Missing Values button to load the Missing Values for … dialog box.
¾ Enter the value –9.000 in the first Global missing values string field.
¾ Click on the OK button of the Missing Values for … dialog box.
¾ Click on the OK button on the Define Variables dialog box.
¾ Select the Save option on the File menu to save the changes to the PSF.

4. Descriptive graphics
A Histogram for MATH1
¾
¾
¾
¾
¾
¾

Use the Open option on the File menu to load the Open dialog box.
Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.
Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.
Select the file JSP2.PSF by clicking on it.
Click on the Open button to open the PSF window for JSP2.PSF.
Select the Univariate option on the Graphs menu of the PSF window to load the
Univariate Plots dialog box.
¾ Select the variable MATH1.
¾ Check the Normal curve overlay checkbox.

An introduction to LISREL 8.80 for Windows

5

¾ Click on the Plot button of the Univariate Plots dialog box to produce following plot
window.

A Scatter Plot for MATH3 and ENG3
¾ Close the plot window above.
¾ Select the Bivariate option on the Graphs menu of the PSF window to load the
Bivariate Plots dialog box.
¾ Select the variable MATH3 by clicking on it.
¾ Click on the Select button in the Y-Variable section.
¾ Select the variable ENG3 by clicking on it.
¾ Click on the Select button in the X-Variable section.
¾ Check the Scatter Plot checkbox.
¾ Click on the Plot button to produce following plot window.
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5. Data screening
¾
¾
¾
¾
¾
¾

Use the Open option on the File menu to load the Open dialog box.
Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.
Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.
Select the file JSP2.PSF by clicking on it.
Click on the Open button to open the PSF window for JSP2.PSF.
Select the Data Screening option on the Statistics menu of the PSF window to open
the following text editor window for JSP2.OUT.
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6. Multiple linear regression analysis
¾
¾
¾
¾
¾
¾
¾
¾
¾
¾
¾

Use the Open option on the File menu to load the Open dialog box.
Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.
Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.
Select the file JSP2.PSF by clicking on it.
Click on the Open button to open the PSF window for JSP2.PSF.
Select the Regressions option on the Statistics menu of the PSF window to load the
Regression dialog box.
Select the variable MATH3 by clicking on it.
Click on the Select button in the Y-Variables section.
Select the variable ENG3 by clicking on it.
Click on the Select button in the X-Variables section.
Click on the Run button to produce following text editor window for JSP2.OUT.

7. Logistic regression analysis
¾
¾
¾
¾
¾
¾
¾
¾
¾
¾
¾

Use the Open option on the File menu to load the Open dialog box.
Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.
Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.
Select the file USA.PSF by clicking on it.
Click on the Open button to open the PSF window for USA.PSF.
Select the Logistic Regressions option on the Statistics menu of the PSF window to
load the Logistic Regression dialog box.
Select the variable NOSAY by clicking on it.
Click on the Add button in the Ordinal Variables section.
Select the variables GENDER and EDUCAT.
Click on the Add button in the Covariates section.
Click on the Run button to produce following text editor window for USA.OUT.
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8. Exploratory factor analysis (EFA)
Continuous variables
¾
¾
¾
¾
¾
¾

Use the Open option on the File menu to load the Open dialog box.
Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.
Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.
Select the file JSP2.PSF by clicking on it.
Click on the Open button to open the PSF window for JSP2.PSF.
Select the Classical Factor Analysis option on the Statistics menu of the PSF window
to load the Classical Factor Analysis dialog box.
¾ Select the variable labels MATH1, MATH2, MATH3, ENG1, ENG2, and ENG3 from the
Variable List box.
¾ Enter 2 in the Number of factors string field.
¾ Click on the Select button to produce the following Classical Factor Analysis dialog
box.
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¾ Click on the Run button to produce the following text editor window for JSP2.OUT.

Ordinal variables
¾ Use the Open option on the File menu to load the Open dialog box.
¾ Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.
¾ Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.
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¾ Select the file USA.PSF by clicking on it.
¾ Click on the Open button to open the PSF window for USA.PSF.
¾ Select the Ordinal Factor Analysis option on the Statistics menu of the PSF window
to load the Ordinal Factor Analysis dialog box.
¾ Select the variable labels NOSAY, VOTING, COMPLEX, NOCARE, TOUCH, and
INTEREST from the Variable List box.
¾ Enter 2 in the Number of factors string field.
¾ Click on the Select button to produce the following Ordinal Factor Analysis dialog box.

¾ Click on the Run button to produce the following text editor window for JSP2.OUT.
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9. Using SIMPLIS syntax files
¾
¾
¾
¾

Use the Open option on the File menu to load the Open dialog box.
Browse for the location C:\LISREL 8.8 Student Examples\SPLEX.
Select the file EX9A.SPL by clicking on it.
Click on the Open button to open the following text editor window for EX9A.SPL.
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Lines 1-2 specify a title for the analysis.
Line 3 specifies source for the labels for the observed variables.
Line 4 specifies the source for the polychoric correlation matrix.
Line 5 specifies the source for the estimated asymptotic covariance matrix of the polychoric
correlations.
Line 6 specifies that the data consist of 410 observations.
Line 7 specifies the labels for the 4 latent variables.
Lines 8-15 specify the model to be fitted to the data.
Line 16 specifies that the Weighted Least Squares (WLS) method for polychoric
correlations should be used to fit the model to the data.
Line 17 requests a path diagram with the results.
Line 18 specifies that no more SIMPLIS commands be processed.
¾ Click on the Run LISREL icon on the main toolbar to produce the following PTH window
for EX9A.PTH.

10. The PTH window for EX9A.PTH
Structural Model
¾ Select the Structural Model option from the Model dropdown list box to produce the
following PTH window.
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Conceptual Path Diagram
¾ Select the Basic Model option from the Model dropdown list box.
¾ Select the Conceptual Diagram option from the Estimates dropdown list box to
produce the following PTH window.
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T-Values
¾ Select the Basic Model option from the Model dropdown list box.
¾ Select the T-values option from the Estimates dropdown list box to produce the
following PTH window.
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11. Using LISREL syntax files
¾
¾
¾
¾

Use the Open option on the File menu to load the Open dialog box.
Browse for the location C:\LISREL 8.8 Student Examples\LS8EX.
Select the file EX1. LS8 by clicking on it.
Click on the Open button to open the following text editor window for EX1.LS8.

Line 1 specifies a title for the analysis.
Line 2 specifies the number of observations (NO=100) and the number of observed
variables of the model (NI=10).
Line 3 specifies the source for the sample covariance matrix of the observed variables of
the model.
Lines 4-7 specify the model to be fitted to the sample covariance matrix specified in line 3.
Line 8 requests a path diagram with the results.
Line 9 specifies the additional results to be written to the output file.
¾ Click on the Run LISREL icon on the main toolbar to produce the following PTH window
for EX9A.PTH.
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