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Introduction
LISREL for Windows (Jöreskog & Sörbom 2005) is a Windows application for structural equation

modeling, multilevel structural equation modeling, multilevel linear and nonlinear modeling,
generalized linear modeling and formal inference-based recursive modeling. It also includes other
statistical methods such as exploratory factor analysis, multiple linear regression analysis, two
stage least squares regression analysis, logistic regression analysis, Probit regression analysis,
censored regression analysis and bootstrapping.
However, it also includes an interactive graphics module which allows users to construct
univariate, bivariate or multivariate graphs. The univariate graphs are bar charts, pie charts and
histograms, the bivariate graphs are Box-and-Whisker plots, three dimensional bar charts, scatter
plots and line plots and multivariate graphs are scatter plot matrices. These graphs can only be
created interactively. In other words, they cannot be created by using syntax files. Once the graphs
are created, they can be exported as Windows metafiles which can be inserted or imported in
applications such as Microsoft Word, Microsoft PowerPoint and Microsoft Excel.
This document is an online guide for using the interactive graphics module of LISREL for Windows
to prepare graphical displays. It supersedes sections 6 and 7 of Chapter 2 and section 7 of Chapter
7 of Du Toit & Du Toit (2001). First, we review the graphical user interface of the graphics module
of LISREL for Windows. Thereafter, we provide illustrative examples of all the available graphs by
using fitness data.
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Graphical user interface
The graphical user interface (GUI) of the interactive graphics module consists of the three options
and dialog boxes on the Graphs menu of the PSF (PRELIS System File) window of LISREL for
Windows. This GUI allows the user to create univariate, bivariate and multivariate graphs
interactively. The Graphs menu, it’s options and the corresponding dialog boxes are reviewed in
this section.

The Graphs menu
The Graphs menu is located on the PSF window of LISREL for Windows which is used to display,
manipulate and process raw data. In other words, one needs to create a PSF and open it in a PSF
window before using any option of the Graph menu interactively. To illustrate this, the PSF
window for the file fitcholplot.psf in the TUTORIAL subfolder with the Graphs menu expanded is
shown below.

The Graphs menu allows the user to create data-based graphs. The Univariate… option provides the
user access to the Univariate Plots dialog box, the Bivariate… option provides the user access to the
Bivariate Plots dialog box and the Multivariate… option provides the user access to the Scatter Plot
Matrix dialog box. Each of these dialog boxes is discussed separately in the next three sections.

The Univariate Plots dialog box

The Univariate Plots dialog box allows the user to create bar charts or pie charts for categorical
variables or histograms for continuous variables. It is accessed by selecting the Univariate… option
on the Graphs menu. This selection loads the Univariate Plots dialog box shown in the image
below.
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The first step is to select a label from the List of variables list box.
When a categorical variable is selected, the Bar chart and Pie chart radio buttons are activated.
Select the desired chart by activating the corresponding radio button.
If a continuous variable is selected, the Histogram section is activated. The Interpolated curve
overlay and the Normal curve overlay check boxes are not checked by default. The user may request
the desired curve(s) by checking the corresponding check box(es). The default number of class
intervals for a histogram is 15. The user may enter an integer between 5 and 14 in the Number of
class intervals string box if 15 is not desired.
Once the user is done with the Univariate dialog box, click on the Plot button to open the specified
plot in a graph window.

The Bivariate Plots dialog box

The Bivariate Plots dialog box allows the user to create Box-and-Whisker plots, three dimensional
bar charts, scatter plots and line plots. It is accessed by selecting the Bivariate… option on the
Graphs menu. This selection loads the following Bivariate Plots dialog box.

LISREL for Windows: Interactive Graphics User’s Guide

3

The user can specify the variable to be plotted on the vertical axis by first selecting the label from
the List of variables list box and then by clicking on the upper Select button to add the variable to
the Y variable grid box. Similarly, the variable to be plotted on the horizontal axis can be selected
by clicking on the lower Select button to add the variable to the X variable grid box.
As shown in the Bivariate Plots dialog box, there are four types of bivariate plots available, namely
Box and Whisker Plot, 3D Bar Chart, Scatter Plot and Line Plot. Only the scatter and line plot can be
requested together by checking the Scatter Plot and Line Plot check boxes. The other two plots can
only be requested one at a time by checking the corresponding check box.
Once the user is done with the Bivariate dialog box, click on the Plot button to open the specified
plot in a graph window.

The Multivariate Plots dialog box

The Multivariate Plots dialog box allows the user to create a scatter plot matrix. It is accessed by
selecting the Multivariate… option on the Graphs menu. This selection loads the following Scatter
Plot Matrix dialog box.
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The user specifies the variables to be plotted by first selecting the labels from the List of Variables
list box and then by clicking on the upper Add button to add the variable to the Selected variable
list box.
Select the variable to be plotted in different colors by first selecting the label from the List of
Variables list box and then by clicking on the lower Add button to add the variable to the Marked by
variable grid box. Note that only categorical variables can be used for this purpose.
Once the user is done with the Bivariate dialog box, click on the Plot button to open the specified
plot in a graph window.
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Examples
LISREL for Windows allows the user to create bar charts, histograms, pie charts, Box and Whisker
plots, 3-dimentional bar charts, scatter plots, line plots and scatter plot matrices interactively. We
illustrate each of these graphs in the subsequent sections by using fitness data. This data set is
described in the next section.

The data
We use fitcholplot.psf in the TUTORIAL subfolder to demonstrate the graphical display features of
LISREL for Windows. There are 60 cases and 8 variables in the data set. The first 10 observations are
shown in the following PSF window.

The -9 entries represent missing values in this data set. There are 3 observations with missing
values.
The variables in the data set are:
o
o
o
o
o
o
o
o
o

Group is the group ID (1 for a weightlifter, 2 for a student and 3 for a marathon athlete).
Age is the age in years.
Length is the height in cm.
Mass is the weight in kg.
%Fat is the percentage fat.
Strength represents the breast-strength in lb.
Trigl is the triglycerides.
Cholest represents the total cholesterol.
Gender is the gender of the respondent.

The continuous variables in this data set are Age, Length, Mass, %Fat, Strength, Trigl and Cholest. The
norminal variables are Group and Gender. More details about the data are available in Du Toit,
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Steyn and Stumpf (1986).

Univariate plots for fitness data
We now use the data in fitchoplot.psf to demonstrate how to produce a bar chart, a pie chart and a
histogram with LISREL for Windows.
Bar chart

We can use the following steps to produce a bar chart for the nominal variable Group in
fitcholplot.psf interactively.
o
o
o
o
o

Select the Open option on the File menu to load the Open dialog box.
Select the PRELIS data (*.psf) option from the Files of type drop-down list box.
Browse for the file fitcholplot.psf in the TUTORIAL subfolder and select it.
Click on the Open button to open fitcholplot.psf in a PSF window.
Select the Univariate option on the Graphs menu as shown below

to activate the Univariate Plots dialog box.
o Select the variable Group from the List of variables list box.
o Activate the Bar chart radio button on the Univariate Plots dialog box to produce the
following dialog box.
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o Click on the Plot button to generate the following graph window.

The default legend shows the categories of the variable Group and the values assigned to each
category. To change the legend of each category, we proceed as follows.
o Double-click on the Cat1:1 description to activate the Text Parameters dialog box.
o Change the text Cat1:1 to 1 = Weightlifter in the Text string field to produce the following
dialog box.
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o Click on the OK button to return to the Graph window.
o Repeat this procedure to change the descriptions of categories 2 and 3 to 2 = Student and 3 =
Marathon athlete respectively
o Click on the OK button to produce the following graph window.

The bar chart above shows that the number of individuals in the first three groups are almost equal
(n = 18, 22 and 20). The appearance of the vertical bars above can be changed as follows.
o Double-click on one of the bars until the Bar Graph Parameters dialog box is activated.
o Select Vert. 3-D bars from the Type drop-down list box.
o Use the Bar Color sliders to select the desired colors to create the following dialog box.

o Click on the OK button to produce the following graph window.
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The above chart may now be printed by selecting the Print option on the File menu. Alternatively, it
can be exported as a Windows metafile (*.wmf) by selecting the Export as Metafile option on the File
menu. The corresponding Windows metafile is saved in the TUTORIAL subfolder.

Pie chart

We now illustrate how to produce a pie chart for the nominal variable Group in fitcholplot.psf
interactively. This is accomplished as follows.
o
o
o
o
o

Select the Open option on the File menu to load the Open dialog box.
Select the PRELIS data (*.psf) option from the Files of type drop-down list box.
Browse for the file fitcholplot.psf in the TUTORIAL subfolder and select it.
Click on the Open button to open fitcholplot.psf in a PSF window.
Select the Univariate option on the Graphs menu as shown below

to activate the Univariate Plots dialog box.
o Select the variable Group from the List of variables list box.
o Activate the Pie chart radio button to produce the following dialog box.
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o Click on the Plot button to produce the following graph window.

The above chart may now be printed by selecting the Print option on the File menu. Alternatively, it
can be exported as a Windows metafile (*.wmf) by selecting the Export as Metafile option on the File
menu. The corresponding Window metafile is saved as fitcholplot.wmf in the current working folder.

Histogram

Suppose we want to obtain a histogram with a Normal curve overlay for the continuous variable
Strength in fitcholplot.psf. We achieve this interactively as follows.
o
o
o
o

Select the Open option on the File menu to load the Open dialog box.
Select the PRELIS data (*.psf) option from the Files of type drop-down list box.
Browse for the file fitcholplot.psf in the TUTORIAL subfolder and select it.
Click on the Open button to open fitcholplot.psf in a PSF window.
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o Select the Univariate option on the Graphs menu as shown below

to activate the Univariate Plots dialog box.
o Select the variable Strength from the List of variables list box.
o Check the Normal curve overlay check box on the Histogram section to produce the
following dialog box.

o Click on the Plot button to produce the following graph window.

The above chart may now be printed by selecting the Print option on the File menu. It can also be
LISREL for Windows: Interactive Graphics User’s Guide

12

exported as a Windows metafile (*.wmf) by selecting the Export as Metafile option on the File menu.
This metafile is saved in the TUTORIAL subfolder.

Bivariate plots for fitness data
In this section, we illustrate how to produce a Box-and-Whisker plot, a three-dimensional bar chart, a
scatter plot and a line plot with LISREL for Windows.
Box and Whisker plot

We now illustrate how to produce a Box and Whisker plot for the continuous variable Cholest for the
three groups in fitcholplot.psf interactively. We accomplish this as follows.
o
o
o
o
o

Select the Open option on the File menu to load the Open dialog box.
Select the PRELIS data (*.psf) option from the Files of type drop-down list box.
Browse for the file fitcholplot.psf in the TUTORIAL subfolder and select it.
Click on the Open button to open fitcholplot.psf in a PSF window.
Select the Bivariate option on the Graphs menu as shown below

o
o
o
o
o

to activate the Bivariate Plots dialog box.
Select the variable Cholest from the List of variables list box.
Click on the upper Select button to add the variable Cholest to the Y variable grid box.
Select the variable Group from the List of variables list box.
Click on the lower Select button to add the variable Group to the X variable grid box.
Check the Box and Whisker Plot check box to produce the following dialog box.
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o Click on the Plot button to open the following graph window.

The above chart may now be printed by selecting the Print option on the File menu. Alternatively, it
can be exported as a Windows metafile (*.wmf) by selecting the Export as Metafile option on the File
menu. The corresponding Windows metafile fitcholplot.wmf is saved in the TUTORIAL subfolder.

3D bar chart

To produce a 3D bar chart of the two nominal variables Gender and Group in fitcholplot.psf, we
proceed as follows.
o
o
o
o
o

Select the Open option on the File menu to load the Open dialog box.
Select the PRELIS data (*.psf) option from the Files of type drop-down list box.
Browse for the file fitcholplot.psf in the TUTORIAL subfolder and select it.
Click on the Open button to open fitcholplot.psf in a PSF window.
Select the Bivariate option on the Graphs menu as shown below
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o
o
o
o
o

to activate the Bivariate Plots dialog box.
Select the variable Gender from the List of variables list box.
Click on the upper Select button to add the variable Gender to the Y variable grid box.
Select the variable Group from the List of variables list box.
Click on the lower Select button to add the variable Group to the X variable grid box.
Check the 3D Bar Chart check box to produce the following dialog box.

o Click on the Plot button to open the following graph window.
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The above plot may now be printed by selecting the Print option on the File menu. It can also be
exported as a Windows metafile (*.wmf) by selecting the Export as Metafile option on the File menu.
The resulting metafile fitcholplot.wmf is saved to the TUTORIAL subfolder.

Scatter plot

Suppose we want to produce a scatter plot of the continuous variables Cholest and Age in
fitcholplot.psf. We accomplish this as follows.
o
o
o
o
o

Select the Open option on the File menu to load the Open dialog box.
Select the PRELIS data (*.psf) option from the Files of type drop-down list box.
Browse for the file fitcholplot.psf in the TUTORIAL subfolder and select it.
Click on the Open button to open fitcholplot.psf in a PSF window.
Select the Bivariate option on the Graphs menu as shown below

o
o
o
o
o

to activate the Bivariate Plots dialog box.
Select the variable Cholest from the List of variables list box.
Click on the upper Select button to add the variable Cholest to the Y variable grid box.
Select the variable Age from the List of variables list box.
Click on the lower Select button to add the variable Age to the X variable grid box.
Check the Scatter Plot check box to produce the following dialog box.
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o Click on the Plot button to open the following graph window.

The above scatter plot may now be printed by selecting the Print option on the File menu.
Alternatively, it can be exported as a Windows metafile (*.wmf) by selecting the Export as Metafile
option on the File menu. The corresponding Windows metafile fitcholplot.wmf is saved in the
TUTORIAL subfolder.

Line plot

Next, we illustrate how to create a line plot of the continuous variables Cholest and %Fat in
fitcholplot.psf.
o
o
o
o
o

Select the Open option on the File menu to load the Open dialog box.
Select the PRELIS data (*.psf) option from the Files of type drop-down list box.
Browse for the file fitcholplot.psf in the TUTORIAL subfolder and select it.
Click on the Open button to open fitcholplot.psf in a PSF window.
Select the Bivariate option on the Graphs menu as shown below
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o
o
o
o
o

to activate the Bivariate Plots dialog box.
Select the variable Cholest from the List of variables list box.
Click on the upper Select button to add the variable Cholest to the Y variable grid box.
Select the variable %Fat from the List of variables list box.
Click on the lower Select button to add the variable Age to the X variable grid box.
Check the Line Plot check box to produce the following dialog box.

o Click on the Plot button to open the following graph window.
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The plot above may now be printed by selecting the Print option on the File menu. Alternatively, it
can be exported as a Windows metafile (*.wmf) by selecting the Export as Metafile option on the File
menu. The corresponding Windows metafile fitcholplot.wmf is saved in the TUTORIAL subfolder.

Multivariate plot (scatter plot matrix) for fitness data
We obtain a scatter plot matrix for the continuous variables Age, Length, Mass, %Fat and Strength in
fitcholplot.psf marked by the variable Group as follows.
o
o
o
o
o

Select the Open option on the File menu to load the Open dialog box.
Select the PRELIS data (*.psf) option from the Files of type drop-down list box.
Browse for the file fitcholplot.psf in the TUTORIAL subfolder and select it.
Click on the Open button to open fitcholplot.psf in a PSF window.
Select the Multivariate option on the Graphs menu as shown below

o
o
o
o

to activate the Multivariate Plots dialog box.
Select the variables Age, Length, Mass, %Fat and Strength from the List of variables list box.
Click on the upper Add button to add them to the Selected list box.
Select the variable Group from the List of variables list box.
Click on the lower Add button to produce the following dialog box.
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o Click on the Plot button to open the following graph window.

The above chart may now be printed by selecting the Print option on the File menu. It can also be
exported as a Windows metafile (*.wmf) by selecting the Export as Metafile option on the File menu. The
corresponding Windows metafile fitcholplot.wmf is saved in the TUTORIAL subfolder.
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