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1. Introduction 
 

LISREL 8.7 for Mac OS 9 and X is Macintosh software for Structural Equation Modeling, 
Multilevel Structural Equation Modeling, Multilevel Linear and Nonlinear Modeling and 
Generalized Linear Modeling.  It consists of the Macintosh text editor application LISREL 
8.7 that interfaces with the Macintosh applications lisrel, prelis, multilevel and 
surveyglim.   
 
The application prelis can be used for manipulating data, transforming data, generating 
data, computing moment matrices, computing asymptotic covariance matrices, performing 
regression analyses, performing exploratory factor analyses, etc. 
 
The application lisrel is intended for Standard and Multilevel Structural Equation Modeling. 
The Full Information Maximum Likelihood (FIML) method for missing data is also available 
for both Standard and Multilevel Structural Equation Modeling.  These methods are 
available for simple random sample data as well as complex survey data. 
 
The application multilevel fits multilevel linear and nonlinear models to raw data.  It allows 
for weights at the different levels of the multilevel hierarchy. 
 
The application surveyglim fits Generalized Linear Models (GLIMs) to simple random 
sample data and complex survey data. 
 
This document is intended as a very brief tutorial to familiarize users of LISREL 8.7 for Mac 
OS 9 and X with the basic use of the software.  Section 2 describes the various files used 
and generated by LISREL 8.7 for Mac OS 9 and X.  The root window of LISREL 8.7 for 
Mac OS 9 and X is reviewed in Section 3.  In Section 4, the processing of a PRELIS syntax 
file is demonstrated.  Thereafter, submitting a LISREL syntax file, a MULTILEVEL syntax 
file and a SurveyGLIM syntax file are illustrated in Sections 5, 6 and 7 respectively.  
Sections 8 and 9 illustrate how to fit a measurement model and a structural equation model 
to data respectively.  The Robust Maximum Likelihood and Weighted Least Squares 
methods are illustrated in Sections 10 and 11 respectively. 
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2. Files 
 

LISREL 8.7 for Mac OS 9 and X uses a PRELIS System File (PSF) to store raw data.  In 
this regard, the application prelis is used to generate PRELIS System Files from text files 
with raw data.  Whenever prelis or lisrel processes a PSF, a Data System File (DSF), 
which has the same file name as the PSF, is created.  This DSF contains all the data 
information (sample size, labels for observed variables, moment matrix, name of the binary 
file containing the estimated asymptotic covariance matrix) that lisrel requires to fit 
structural equation models to the data. 
 
A structural equation model can be specified by means of a SIMPLIS syntax file or a 
LISREL syntax file.  SIMPLIS and LISREL syntax files are text files with the default 
extensions SPL and LS8 respectively.  These two file types can access the data from the 
PSF, the DSF or the text data file.  If a user has prepared any of these files, then LISREL 
8.7 for Mac OS 9 and X can be used to fit the specified model to the data specified in the 
corresponding PSF or DSF. 
 
SIMPLIS syntax files are described in Jöreskog & Sörbom (1999c) while the LISREL syntax 
files are outlined in Jöreskog & Sörbom (1999b).  These files are also described in the 
online Help File of LISREL 8.7 for Mac OS 9 and X. 
  
A PRELIS syntax file is a text file with default extension PR2.  PRELIS syntax files are 
described by Jöreskog & Sörbom (1999a) as well as in the online Help File of LISREL 8.7 
for Mac OS 9 and X.   
 
Multilevel Modeling syntax files are also text files with default extension PR2.  Multilevel 
Modeling syntax files are described in Jöreskog et al. (2001).  These syntax files are also 
described in the online Help file of LISREL 8.7 for Mac OS 9 and X. 
 
SurveyGLIM syntax files are described in the online Help file of LISREL 8.7 for Mac OS 9 
and X. 
 
The application LISREL 8.7 starts up by opening a root window with ten menus.  The File 
menu can then be used to create new or open existing PRELIS, LISREL, SIMPLIS, 
MULTILEVEL and SurveyGLIM syntax files and output files.  The Start menu is used to 
open the applications prelis, lisrel, multilevel and surveyglim. 
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3. The LISREL 8.7 Root Window 
 

Once the application LISREL 8.7 is opened by, for example, double-clicking on the LISREL 
8.7 icon, the following root window is opened. 
 

 
  
The Apple menu of the root Window has the standard options of the Apple menu with a 
special option for About LISREL 8.7 for Mac OS 9 and X. 
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The options on the File menu are: 

  
These options are the standard file options of any standard Macintosh text editor such as 
SimpleText or TextEdit. 
 
The options on the Edit menu are: 

 
 
These options are the standard edit options of any standard Macintosh text editor such as 
SimpleText or TextEdit. 
 
The options on the Start menu are: 

 
 
The PRELIS option loads the following dialog box. 
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Actions 

 Locate the application prelis in the folder in which LISREL 8.7 for Mac OS 9 and X is 
installed. 

 Select the application prelis. 
 Click on the Open button to open prelis. 

 
The LISREL option loads the following dialog box. 

 
Actions 

 Locate the application lisrel in the folder in which LISREL 8.7 for Mac OS 9 and X is 
installed. 

 Select the application lisrel. 
 Click on the Open button to open lisrel. 

 
The MULTILEVEL option loads the following dialog box. 

 
 
Actions 

 Locate the application multilevel in the folder in which LISREL 8.7 for Mac OS 9 and X 
is installed. 

 Select the application multilevel. 
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 Click on the Open button to open multilevel. 
 
The SurveyGLIM option loads the following dialog box. 

 
 
Actions 

 Locate the application surveyglim in the folder in which LISREL 8.7 for Mac OS 9 and 
X is installed. 

 Select the application surveyglim. 
 Click on the Open button to open surveyglim. 

 
The Online Help File option loads the following dialog box. 

 
Actions 

 Locate the file LISMAC.HTM in the HELP folder of the folder in which LISREL 8.7 for 
Mac OS 9 and X is installed. 

 Select the file LISMAC.HTM. 
 Click on the Open button to open LISMAC.HTM. 

 
The options on the Font menu are: 
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This menu allows the user to set the font for LISREL 8.7 syntax and output files. 
 
The options on the Size menu are: 

 
This menu allows the user to set the font size for LISREL 8.7 syntax and output files. 
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The options on the Style menu are: 

 
This menu allows the user to set the character style for LISREL 8.7 syntax and output files. 
 
The options on the Colour menu are: 

 
This menu allows the user to set the font color for LISREL 8.7 syntax and output files. 
 
The options on the Justification menu are: 

 
This menu allows the user to set the paragraph justification for LISREL 8.7 syntax and 
output files. 
 
The options on the Window menu are: 

 
This menu allows the user to manage the open windows of LISREL 8.7. 
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4. Submitting a PRELIS Syntax File 
 

The following stepwise procedure may be used to process the PRELIS syntax file 
EX11.PR2 with LISREL 8.7. 
 

 Select the PRELIS option on the Start menu to load the Open: The PRELIS 
Application dialog box. 

 Locate the application prelis in the folder in which LISREL 8.7 for Mac OS 9 and X is 
installed. 

 Select the application prelis. 
 Click on the Open button to load the prelis Open dialog box. 
 Locate the file EX11.PR2. 
 Select the file EX11.PR2 to produce the following dialog box. 

 

 
 

 Click on the Open button to open the following text editor window. 

9 
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5. Submitting a LISREL Syntax File 
 

The following steps may be followed to process the LISREL syntax file EX1.LS8 with 
LISREL 8.7. 
 

 Select the LISREL option on the Start menu to load the Open: The LISREL 
Application dialog box. 

 Locate the application lisrel in the folder in which LISREL 8.7 for Mac OS 9 and X is 
installed. 

 Select the application lisrel. 
 Click on the Open button to load the lisrel Open dialog box. 
 Locate the file EX1.LS8. 
 Select the file EX1.LS8 to produce the following dialog box. 

 

 
 

 Click on the Open button to open the following text editor window. 

11 
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6. Submitting a MULTILEVEL Syntax File 

 
The following stepwise procedure may be used to process the MULTILEVEL syntax file 
CONS.PR2 with LISREL 8.7. 
 
Generating CONS1A.PSF 

 Select the PRELIS option on the Start menu to load the Open: The PRELIS 
Application dialog box. 

 Locate the application prelis in the folder in which LISREL 8.7 for Mac OS 9 and X is 
installed. 

 Select the application prelis. 
 Click on the Open button to load the prelis Open dialog box. 
 Locate the file CONS1A.PR2. 
 Select the file CONS1A.PR2 to produce the following dialog box. 

 
 

 Click on the Open button to open the following text editor window. 
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Multilevel Modeling 
 

 Select the MULTILEVEL option on the Start menu to load the Open: The Multilevel 
Modeling Application dialog box. 

 Locate the application multilevel in the folder in which LISREL 8.7 for Mac OS 9 and X 
is installed. 

 Select the application multilevel. 
 Click on the Open button to load the multilevel Open dialog box. 
 Locate the file CONS.PR2. 
 Select the file CONS.PR2 to produce the following dialog box. 
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 Click on the Open button to open the following text editor window. 
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7. Submitting a SurveyGLIM Syntax File 
 

The following stepwise procedure may be used to process the MULTILEVEL syntax file 
GLIMEX1.PR2 with LISREL 8.7. 
 
Generating ABUSE1.PSF 

 Select the PRELIS option on the Start menu to load the Open: The PRELIS 
Application dialog box. 

 Locate the application prelis in the folder in which LISREL 8.7 for Mac OS 9 and X is 
installed. 

 Select the application prelis. 
 Click on the Open button to load the prelis Open dialog box. 
 Locate the file ABUSE1A.PR2. 
 Select the file ABUSE 1A.PR2 to produce the following dialog box. 

 
 

 Click on the Open button to open the following text editor window. 
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Generalized Linear Modeling 
 

 Select the SurveyGLIM option on the Start menu to load the Open: The SurveyGLIM 
Modeling Application dialog box. 

 Locate the application surveyglim in the folder in which LISREL 8.7 for Mac OS 9 and 
X is installed. 

 Select the application surveyglim. 
 Click on the Open button to load the surveyglim Open dialog box. 
 Locate the file SGLIMEX1.PR2 in the SGLIMEX folder. 
 Select the file SGLIMEX1.PR2 to produce the following dialog box. 
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 Click on the Open button to open the following text editor window. 
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8. Fitting a Measurement Model to Raw Data 
 

The text data file DEPRESS.DAT contains 204 observations of 12 continuous indicators of 
three latent variables.  More specifically, the first 5 indicators (SELF1 to SELF5) are 
indicators of the latent variable Self-esteem, DEPRES1 to DEPRES4 are indicators of the 
latent variable Depressiveness and IMPULS1 to IMPULS3 are indicators of the latent 
variable Impulsiveness.  The theoretical measurement model is a CFA model that specifies 
that the 12 continuous indicators are indeed indicators of Self-esteem, Depressiveness and 
Impulsiveness.  A step-by-step procedure to fit this measurement model to the text data set 
follows. 
 
Creating DEPRESS.PSF 

 Select the New option on the File menu to load the New Syntax File window. 
 Enter the following commands one by one. 

 

 
 
Line 1 specifies that 12 variables are to be read (NI=12) and that list wise deletion should 
be applied to missing values (TR=LI). 
Lines 2-3 specify the labels for the 12 observed variables. 
Line 4 specifies the name of the text data file. 
Line 5 specifies that all variables are continuous. 
Line 6 specifies that the raw data in the text data file should be written to the PSF (binary 
file) DEPRESS.PSF. 

 Select the Save As option on the File menu to load the Save As dialog box. 
 Enter the name DEPRESSPSF.PR2 for the PRELIS syntax file. 
 Click on the Save button. 
 Close the syntax file window. 
 Select the PRELIS option on the Start menu to load the Open: The PRELIS 

Application dialog box. 
 Locate the application prelis in the folder in which LISREL 8.7 for Mac OS 9 and X is 

installed. 
 Select the application prelis. 
 Click on the Open button to open prelis. 
 Locate the PRELIS syntax file DEPRESSPSF.PR2. 
 Click on the Open button to open the following output window. 
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Fitting the measurement model 

 Select the New option on the File menu to load the New Syntax File window. 
 Enter the following commands one by one. 
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Line 1 specifies the source for the raw data file. 
Lines 2-3 specify the labels for the 3 latent variables. 
Lines 4-7 specify the measurement model for the 3 latent variables. 
Line 8 specifies that the results should be reported in the form of the LISREL model for the 
measurement model. 

 Select the Save As option on the File menu to load the Save As dialog box. 
 Enter the name DEPRESS1.SPL for the SIMPLIS syntax file. 
 Click on the Save button. 
 Close the syntax file window. 
 Select the LISREL option on the Start menu to load the Open: The LISREL 

Application dialog box. 
 Locate the application lisrel in the folder in which LISREL 8.7 for Mac OS 9 and X is 

installed. 
 Select the application lisrel. 
 Click on the Open button to open lisrel. 
 Locate the PRELIS syntax file DEPRESS1.SPL. 
 Click on the Open button to open the following output window. 
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9. Fitting a Structural Equation Model to raw data 
 

The text data file DEPRESS.DAT contains 204 observations of 12 continuous indicators of 
three latent variables.  More specifically, the first 5 indicators (SELF1 to SELF5) are 
indicators of the latent variable Self-esteem, DEPRES1 to DEPRES4 are indicators of the 
latent variable Depressiveness and IMPULS1 to IMPULS3 are indicators of the latent 
variable Impulsiveness.  The theoretical measurement model is a CFA model that specifies 
that the 12 continuous indicators are indeed indicators of Self-esteem, Depressiveness and 
Impulsiveness. One possible structural model for the three latent variables is a model that 
suggests that Depressiveness and Impulsiveness are correlated antecedents of Self-
esteem.  A step-by-step procedure to fit this latent variable model to the text data set 
follows. 
 
Creating DEPRESS.PSF 
Use the steps in section 7 to create of the PSF DEPRESS.PSF if it has not yet been 
created. 
 
Fitting the structural equation model 

 Select the New option on the File menu to load the New Syntax File window. 
 Enter the following commands one by one. 

 
 
Line 1 specifies the source for the raw data file. 
Lines 2-3 specify the labels for the 3 latent variables. 
Lines 4-7 specify the measurement model for the 3 latent variables. 
Lines 8-9 specify the structural model for the latent variables. 
Line 10 specifies that the results should be reported in the form of the LISREL model for 
the structural equation model. 

 Select the Save As option on the File menu to load the Save As dialog box. 
 Enter the name DEPRESS2.SPL for the SIMPLIS syntax file. 
 Click on the Save button. 
 Close the syntax file window. 
 Select the LISREL option on the Start menu to load the Open: The LISREL 

Application dialog box. 
 Locate the application lisrel in the folder in which LISREL 8.7 for Mac OS 9 and X is 

installed. 
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 Select the application lisrel. 
 Click on the Open button to open lisrel. 
 Locate the PRELIS syntax file DEPRESS2.SPL. 
 Click on the Open button to open the following output window. 
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10. Robust Maximum Likelihood 
 

Browne (1987) formulated a Robust Maximum Likelihood (RML) method for factor analysis 
and related models.  Satorra & Bentler (1988) extended this method by providing a correct 
Chi-square test statistic.  This method is available in LISREL 8.7 for Mac OS 9 and X and 
the associated formulae are provided in Jöreskog et al (2001).  To implement this method, 
the user needs to compute the Asymptotic Covariance Matrix (ACM) of the sample 
variances and covariances.  A step-by-step procedure to implement the RML method in 
LISREL 8.7 for Mac OS 9 and X for the structural equation model of section 4 may be 
described as follows. 
 
Creating DEPRESS.DSF 

 Select the New option on the File menu to load the New Syntax File window. 
 Enter the following commands one by one. 

 

 
 
 

Line 1 specifies the source for the raw data file. 
Line 2 specifies that the sample covariance matrix should be computed (MA=CM) and that 
the estimated asymptotic covariance matrix of the sample variances and covariances 
should be computed and written to the binary file DEPRESS.ACM. 
 
 

 Select the Save As option on the File menu to load the Save As dialog box. 
 Enter the name DEPRESS.PR2 for the PRELIS syntax file. 
 Click on the Save button. 
 Close the syntax file window. 
 Select the PRELIS option on the Start menu to load the Open: The PRELIS 

Application dialog box. 
 Locate the application prelis in the folder in which LISREL 8.7 for Mac OS 9 and X is 

installed. 
 Select the application prelis. 
 Click on the Open button to open prelis. 
 Locate the PRELIS syntax file DEPRESS.PR2. 
 Click on the Open button to open the following output window. 
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The Robust Maximum Likelihood method 

 Select the New option on the File menu to load the New Syntax File window. 
 Enter the following commands one by one. 
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Line 1 specifies the source for the binary summary data file. 
Lines 2-3 specify the labels for the 3 latent variables. 
Lines 4-7 specify the measurement model for the 3 latent variables. 
Lines 8-9 specify the structural model for the latent variables. 
Line 10 specifies that the results should be reported in the form of the LISREL model for 
the structural equation model. 

 Select the Save As option on the File menu to load the Save As dialog box. 
 Enter the name DEPRESS3.SPL for the SIMPLIS syntax file. 
 Click on the Save button. 
 Close the syntax file window. 
 Select the LISREL option on the Start menu to load the Open: The LISREL 

Application dialog box. 
 Locate the application lisrel in the folder in which LISREL 8.7 for Mac OS 9 and X is 

installed. 
 Select the application lisrel. 
 Click on the Open button to open lisrel. 
 Locate the PRELIS syntax file DEPRESS3.SPL. 
 Click on the Open button to open the following output window. 
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11. Weighted Least Squares 
 

Browne (1982, 1984) formulated an Asymptotically Distribution Free (ADF) method for 
covariance structures.  This method is implemented in LISREL 8.7 for Mac OS 9 and X as 
Weighted Least Squares (WLS) and extended to correlation structures.  To implement this 
method, the user needs to compute the Asymptotic Covariance Matrix (ACM) of the sample 
variances and covariances or sample correlations.  A step-by-step procedure to implement 
the WLS method in LISREL 8.7 for Mac OS 9 and X for the structural equation model of 
sections 4 and 5 may be described as follows. 
 
Creating DEPRESS.DSF 
Generate the Data System File (DSF) DEPRESS.DSF“ exactly as described in section 9 if 
it has not yet been generated. 
 
The Weighted Least Squares method 

 Select the New option on the File menu to load the New Syntax File window. 
 Enter the following commands one by one. 

 
Line 1 specifies the source for the binary summary data file. 
Lines 2-3 specify the labels for the 3 latent variables. 
Lines 4-7 specify the measurement model for the 3 latent variables. 
Lines 8-9 specify the structural model for the latent variables. 
Line 10 specifies that the results should be reported in the form of the LISREL model for 
the structural equation model. 

 Select the Save As option on the File menu to load the Save As dialog box. 
 Enter the name DEPRESS4.SPL for the SIMPLIS syntax file. 
 Click on the Save button. 
 Close the syntax file window. 
 Select the LISREL option on the Start menu to load the Open: The LISREL 

Application dialog box. 
 Locate the application lisrel in the folder in which LISREL 8.7 for Mac OS 9 and X is 

installed. 
 Select the application lisrel. 
 Click on the Open button to open lisrel. 
 Locate the PRELIS syntax file DEPRESS4.SPL. 
 Click on the Open button to open the following output window. 
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